routeros 3322电信联通脚本

                                               3322电信联通脚本

:log info "LianTong 3322" 
:local ednsuser "wf12"
:local ednspass "gsel33"
:local ednshost "wfdblt.f3322.net"
:local ednsinterface "liantong"
:local members "http://members.3322.org/dyndns/update?system=dyndns"
#:local members "http://members.dyndns.org/nic/update?"
:local status
:local status [/interface get [/interface find  name=$ednsinterface] running]
:if ($status!=false) do={
  :local ednslastip [:resolve $ednshost]
  :if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip "0" }
  :local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
  :log info ("3322-dynamic-dns:" . $ednshost . " IP-Address:" . $ednsiph)
  :local ednsip [:pick $ednsiph 0 [:find $ednsiph "/"]]
  :local ednsstr "&hostname=$ednshost&myip=$ednsip"
  :if ($ednslastip != $ednsip) do={
    /tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
    :delay 2
    :local result [/file get $ednshost contents]
    :log info ($ednshost . " " .$result)
    /file remove $ednshost ;
  }
}

:log info "DianXin_3322_" 
:local ednsuser "wf12"
:local ednspass "gsel33"
:local ednshost "wfdbdx.f3322.net"
:local ednsinterface "dianxin"
:local members "http://members.3322.org/dyndns/update?system=dyndns"
#:local members "http://members.dyndns.org/nic/update?"
:local status
:local status [/interface get [/interface find  name=$ednsinterface] running]
:if ($status!=false) do={
  :local ednslastip [:resolve $ednshost]
  :if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip "0" }
  :local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
  :log info ("3322-dynamic-dns:" . $ednshost . " IP-Address:" . $ednsiph)
  :local ednsip [:pick $ednsiph 0 [:find $ednsiph "/"]]
  :local ednsstr "&hostname=$ednshost&myip=$ednsip"
  :if ($ednslastip != $ednsip) do={
    /tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
    :delay 2
    :local result [/file get $ednshost contents]
    :log info ($ednshost . " " .$result)
    /file remove $ednshost ;
  }
}

猜你喜欢

转载自blog.csdn.net/wdhqwe520/article/details/90109446