C语言编程100题-6.5

6.5
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification:
Each input contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format: ID_number Sign_in_time Sign_out_time where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.
Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space. Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
样例输入:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
样例输出:
SC3021234 CS301133

#include<stdio.h>
#include <string.h>
int main()
{
	char id_num[16], max_id_num[16], min_id_num[16];//字符数目+1,15+1=16
	char in_time[16], out_time[16], min_in_time[16], max_out_time[16];
	int total, i;
	scanf("%d", &total);
	int is_first = 1;
	for (i = 0; i < total; i++)
	{
		scanf("%s%s%s", id_num, in_time, out_time);
		if (is_first)//默认第一个人是最早来最晚走
		{
			strcpy(max_id_num, id_num);
			strcpy(min_id_num, id_num);
			strcpy(max_out_time, out_time);
			strcpy(min_in_time, in_time);
			is_first = 0;
		}
		else
		{
			if (strcmp(max_out_time, out_time) < 0)//若前者比后者早走,留后者
			{
				strcpy(max_out_time, out_time);
				strcpy(max_id_num, id_num);
			}
			if (strcmp(min_in_time, in_time) > 0)//若前者比后者晚来,留后者
			{
				strcpy(min_in_time, in_time);
				strcpy(min_id_num, id_num);
			}
		}
	}
	printf("%s %s", min_id_num, max_id_num);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nollysoul/article/details/89819957