#POJ 1125 Stockbroker Grapevine (floyed)

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.
 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

题目大意 : 给出一个有向图,求所有点到其他点距离之和的最短的那个点, 并输出该点的序号和他到其他点路径的最小值。

思路 : 先用floyed求出多源点之间的距离, 再枚举各个点, 用结构体保存数据,最后排序输出就OK了。特殊情况:如果有点与其他点都不相连,输出“disjoint”, 这个只要在枚举的过程中令一个 tot = 0, 如果碰到  P[i][j] = P[j][i] = INF,就 + 1, 如果tot == n - 1, 说明除了自己,没有点和他相连。水题。。

AC代码 : 

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 1e2 + 5;
const int INF = 1e8;

struct node
{
    int id, sum, ans;  //id表示序号, sum 表示 到其他源点的和, ans表示到其他源点的最小值
    bool operator < (const node &oth) const
    {
        return sum < oth.sum;
    }
}e[maxn];
int p[maxn][maxn], n;
void init() {
    for (int i = 1; i <= n; i++) {
        for (int j = 1; j <= n; j++) {
            if (i == j) p[i][j] = 0;
            else p[i][j] = INF;
        }
    }
    memset(e, 0, sizeof(e));
}

int main()
{
    while (cin >> n && n) {
        init();
        for (int i = 1; i <= n; i++) {
            int num;
            cin >> num;
            for (int j = 0; j < num; j++) {
                int vi, wi;
                cin >> vi >> wi;
                p[i][vi] = min (p[i][vi], wi);
            }
        }
        for (int k = 1; k <= n; k++) {
            for (int i = 1; i <= n; i++) {
                for (int j = 1; j <= n; j++)
                    p[i][j] = min (p[i][j], p[i][k] + p[k][j]);
            }
        }
        for (int i = 1; i <= n; i++) {
            int tot = 0;
            e[i].ans = -INF;
            e[i].id = i;
            for (int j = 1; j <= n; j++) {
                if (i == j) continue;
                if (p[i][j] == INF && p[j][i] == INF) tot++;
                else e[i].sum += p[i][j], e[i].ans = max (e[i].ans, p[i][j]);
            }
            if (tot == n - 1) {cout << "disjoint" << endl; return 0;}
        }
        sort (e + 1, e + n + 1);
        cout << e[1].id << " " << e[1].ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43851525/article/details/91352815
今日推荐