M - Highways

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can’t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input
9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output
1 6
3 7
4 9
5 7
8 3

输出部分写的不好

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define N 755
#define eps 1e-6
#define INF 0x3f3f3f3f
using namespace std;
struct Node{
	double x,y;
}a[N];
double dis[N][N];
int flag[N];
double res[N];
	int n,m;
double dist(Node aa,Node bb){
	return sqrt(  (aa.x-bb.x)*(aa.x-bb.x) +(aa.y-bb.y)*(aa.y-bb.y) );
}

void Dijkstra()
{	
	int add=1;
	res[add]=0;
	while(1){
		flag[add]=1;
		for(int i=1;i<=n;i++){
			if(flag[i]) continue;
			res[i]=min( res[i] , dis[add][i] );
		}		
		//优化完成
		double minnum=INF;
		int minid=-1;
		
		 for(int i=1;i<=n;i++){
		 	if(flag[i]) continue;
		 	if( res[i] < minnum ){
		 		minnum=res[i];
		 		minid=i;
			 }
		 }
		 
		 if(minid==-1) break;
		 add=minid;
		 if(minnum==0) continue;
		for(int i=1;i<=n;i++){
			if(flag[i]){
				if( dis[minid][i]==minnum ){
					printf("%d %d\n",minid,i);
					break;
				}
			}
		} 
	}

}
int main(){
	memset(flag,0,sizeof(flag));
	cin>>n;
	for(int i=1;i<=n;i++){
		scanf("%lf %lf",&a[i].x,&a[i].y);
		res[i]=INF;
	}
	for(int i=1;i<=n;i++)
		for(int j=i+1;j<=n;j++)
			dis[i][j]=dis[j][i]=dist( a[i],a[j] );			
	cin>>m;
	for(int i=1;i<=m;i++){
		int u,v;
		scanf("%d %d",&u,&v);
		dis[u][v]=dis[v][u]=0;
	}
	//建图完成
	Dijkstra(); 
	return 0;
}

输出可以这样写


            if( res[i] > dis[add][i] ){
				res[i] = dis[add][i];
				road[i]=add;
			}
		


 if(minid==-1) break;
		 add=minid;
		 if(minnum==0) continue;
		printf("%d %d\n",minid,road[minid]);

猜你喜欢

转载自blog.csdn.net/weixin_44532671/article/details/92992335
M
^M