Labyrinth 树的直径加DFS

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input

2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output

Maximum rope length is 0.
Maximum rope length is 8.

Hint

Huge input, scanf is recommended. 
If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc
题目大意:在给定的图中寻找两个“.”之间最大的距离
思路  :两次DFS即可第一遍随便找个点,寻找到这个点最远的点p,第二遍DFS以p点开始,寻找到P点最远的点
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,m;
char arr[1500][1500];
int start_i,start_j;
int mark[1500][1500];
//int arr1[1500][1500];
int ans=0;
int xx,yy;
int d[4][2]={{1,0},{0,1},{0,-1},{-1,0}};
void dfs(int x,int y,int step){
    if(step>ans){
        ans=step;//寻找距离x,y最远的点并记录下来
        xx=x;
        yy=y;
    }

    for(int i=0;i<4;i++)
    {
        int dx=x+d[i][0];
        int dy=y+d[i][1];
        if(dx>=0&&dy>=0&&dx<n&&dy<m&&arr[dx][dy]=='.'&&mark[dx][dy]==0){
            mark[dx][dy]=1;
            dfs(dx,dy,step+1);
            mark[dx][dy]=0;//回溯
        }
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--){
        
        cin>>m>>n;//n行m列
        for(int i=0;i<n;i++){
            scanf("%s",&arr[i]);
        }
        int j;
        for(int i=0;i<n;i++)
        {
            for(j=0;j<m;j++){
                if(arr[i][j]=='.'){
                    start_i=i;
                    start_j=j;
//                    cout<<i<<"_"<<j<<endl;
                    break;
                }
            }
            if(j!=m)
                    break;
        }
            ans=0;
            memset(mark,0,sizeof(mark));
            mark[start_i][start_j]=1;
            dfs(start_i,start_j,0);
            memset(mark,0,sizeof(mark));
            dfs(xx,yy,0);
            printf("Maximum rope length is %d.\n",ans);
    }
    
    
    return 0;
 } 
 
 

猜你喜欢

转载自www.cnblogs.com/Accepting/p/11243598.html