1045 Favorite Color Stripe (30 point(s)) - C语言 PAT 甲级

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/huaxuewan/article/details/102414797

1045 Favorite Color Stripe (30 point(s))

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.
It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.
Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤ 200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤ 104) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

题目大意:

输入 N 表示有 N 种颜色,M 表示喜欢其中的 M 种颜色,然后给一串长为 L 的颜色序列,去除不喜欢的颜色,求剩下序列中颜色顺序符合喜欢颜色顺序的子序列;

输出符合条件的子序列最大长度;

例如有 6 种颜色,喜欢的颜色顺序为 {2 3 1 5 6},给一串颜色顺序为 {2 2 4 1 5 5 6 3 1 1 5 6},有四个符合条件的最长子序列 {2 2 1 1 1 5 6},{2 2 1 5 5 5 6},{2 2 1 5 5 6 6} 和 {2 2 3 1 1 5 6},输出最长的长度 7

设计思路:

仅需要输出子序列最长的长度,可按照递增子序列记录长度;

  • 喜欢的颜色顺序为 {2 3 1 5 6},遍历 {2 2 4 1 5 5 6 3 1 1 5 6},
    • 当遍历到的颜色为 2,则当前以 2 结尾的子序列最长长度为之前以 2 结尾子序列的最大值加 1,
    • 当遍历到的颜色为 3,则当前以 3 结尾的子序列最长长度为之前以 2 或以 3 结尾子序列的最大值加 1,
    • 当遍历到的颜色为 1,则当前以 1 结尾的子序列最长长度为之前以 2 或 3 或 1 结尾子序列的最大值加 1,
    • ……
    • 最终记录到最长子序列长度即为符合条件的最长长度
  • 程序中具体实现未完全按照上述思路
    • 当遍历到的颜色为 2,则以 2 结尾的子序列最长长度加 1,并更新以 3,1,5,6 结尾的子序列最长长度为以 2 结尾或以自身结尾序列的较大值
    • 当遍历到的颜色为 3,则以 3 结尾的子序列最长长度加 1,并更新以 1,5,6 结尾的子序列最长长度为以 3 结尾或以自身结尾序列的较大值
    • ……
    • 最终最大长度直接输出以 6 结尾的子序列长度
  • 存储过程中按照喜欢颜色的索引值记录
编译器:C (gcc)
#include <stdio.h>

int main(void)
{
        int map[201], a[10001], dp[201] = {0};
        int n, m, l, color, count = 0;
        int i, j;

        scanf("%d %d", &n, &m);
        for (i = 1; i <= m; i++) {
                scanf("%d", &color);
                map[color] = i;
        }
        scanf("%d", &l);
        for (i = 0; i < l; i++) {
                scanf("%d", &color);
                if (map[color] > 0) {
                        a[count] = map[color];
                        count++;
                }
        }

        for (i = 0; i < count; i++) {
                color = a[i];
                dp[color]++;
                for (j = color + 1; j <= m && dp[j] < dp[color]; j++) {
                        dp[j] = dp[color];
                }
        }

        printf("%d", dp[m]);

        return 0;
}

猜你喜欢

转载自blog.csdn.net/huaxuewan/article/details/102414797