PTA(Advanced Level)1025.PAT Ranking

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
思路
  • 每次读进来一组数据就进行一次排序,同时要注意相同分数的情况下排名要顺延,也就是说100 95 95 85 77对应的名次是1 2 2 4 5
代码
#include<bits/stdc++.h>
using namespace std;
struct node
{
    char id[15];
    int score;
    int loc;    //location
    int loc_rank;
    int all_rank;
}a[30010];
int a_num = 0;

bool cmp(node a, node b)
{
    if(a.score != b.score)
        return a.score > b.score;
    else return strcmp(a.id, b.id) < 0;
}


int main()
{
    int cases;
    scanf("%d", &cases);
    int cnt = 0;
    int level = 1;
    int n;
    while(cases--)
    {
        scanf("%d", &n);
        for(int j=0;j<n;j++)
        {
            scanf("%s %d", a[a_num].id, &a[a_num].score);
            a[a_num].loc = level;
            a_num++;
        }
        sort(a + cnt, a + cnt + n, cmp);
        a[cnt].loc_rank = 1;

        for(int i=cnt+1;i<cnt+n;i++)
        {
            if(a[i].score == a[i-1].score)
                a[i].loc_rank = a[i-1].loc_rank;
            else
                a[i].loc_rank = i - (cnt + 1) + 2;
        }//对每个loc进行单独的排序
        cnt += n;
        level++;
    }
    sort(a, a + a_num, cmp);
    a[0].all_rank = 1;
    for(int i=1;i<a_num;i++)
    {
        if(a[i].score == a[i-1].score)
            a[i].all_rank = a[i-1].all_rank;
        else
            a[i].all_rank = i + 1;
    }
    printf("%d\n", cnt);
    for(int i=0;i<a_num;i++)
    {
        printf("%s %d %d %d\n", a[i].id, a[i].all_rank, a[i].loc, a[i].loc_rank);
    }
    return 0;
}
引用

<https://pintia.cn/problem-sets/994805342720868352/problems/994805474338127872P

猜你喜欢

转载自www.cnblogs.com/MartinLwx/p/11788409.html