字典树-Phone List及清空字典树(避免Memory Limit Exceeded)

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1.Emergency 911
2.Alice 97 625 999
3.Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES

有t(1<=t<=40)组测试,每组测试有n(1<=n<=10000)个电话号码,电话号码最长为10,判断有无电话号码前面部分(从第一个数字开始算)的数字为另一个电话号码,有则输出NO
运行例子:
2
2
123456
12345
NO
2
123456
456
YES
第一组第一个号码123456前面5个数字包含第二个号码12345,则输出NO
第二组第一个号码123456虽然包括456但前面还有123,即输出YES
每组测试要释放字典树的空间,否则重复申请空间会导致超出内存限制

#include<iostream>
#include<cstring>
using namespace std;
struct tree
{
    bool e;//号码结尾
    tree *n[10];//下一个数字,下标1-9对应号码的数字1-9
    tree()
    {
        e=false;//非结尾时为false
        memset(n,NULL,sizeof(n));
    }
};
bool inser(char[],int,tree*);//将号码输入字典树
void init(tree*);//释放空间
int main()
{
    int t,n;
    char p[11];
    bool b;
    cin>>t;
    while(t--)
    {
        tree *root=new tree;
        b=false;
        cin>>n;
        while(n--)
        {
            cin>>p;
            if(!b)b=inser(p,strlen(p),root);//如果已发现包含便不再需要输入字典树
        }
        if(!b)cout<<"YES\n";
        else cout<<"NO\n";
        init(root);
    }
    return 0;
}
bool inser(char p[] ,int l,tree *root)
{
    int i,j;
    bool b=false;//记录这次输入是否有申请新空间,即之前有无出现过这种号码,无则为false
    tree *branch=root;
    for(i=0;i<l;i++)
    {
        j=p[i]-'0';
        if(branch->n[j]==NULL)
        {
            branch->n[j]=new tree;
            b=true;
        }
        branch=branch->n[j];
        if(branch->e)return true;//遇到之前的号码的尾数则说明包含了之前的号码
    }
    branch->e=true;
    if(b)return false;//没有申请新空间说明该号码的所有数字对应的空间在之前都被另一个号码申请了,该号码被包含
    else return true;
}
void init(tree *root)
{
    int i;
    tree *branch=root;
    for(i=0;i<=9;i++)
        if(branch->n[i]!=NULL)init(branch->n[i]);//递到最远处再释放回分岔点,再递到另一条最远处再释放回来,直到分岔点为根
    delete root;
}

猜你喜欢

转载自www.cnblogs.com/MTstory/p/12049728.html