COURSES POJ - 1469 匈牙利模板

一、内容

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:


    every student in the committee represents a different course (a student can represent a course if he/she visits that course)
    each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student 1 1 Student 1 2 ... Student 1 Count1
Count2 Student 2 1 Student 2 2 ... Student 2 Count2
...
CountP Student P 1 Student P 2 ... Student P CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.

Output
The result of the program is on the standard output. For each input data set the program prints on a single line “YES” if it is possible to form a committee and “NO” otherwise. There should not be any leading blanks at the start of the line.
Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

二、思路

  • 有p个课程,题目让给每个课程都找一个课代表(学生),问最多能够找多少个课代表。一个学生只能当一个课代表
  • 可以讲课程看做左边的点,学生看做右边的点,它们之间有连边,求最大的匹配数是否等于课程数即可。

三、代码

#include <cstdio>
#include <cstring> 
using namespace std;
const int N = 305, M = 50005;
struct E {
	int v, next;
} e[M];
int t, n, m, p, k, v, head[N], len, mat[N];
bool vis[N];  
void add(int u, int v) {
	e[len].v = v;
	e[len].next = head[u];
	head[u] = len++;
} 
bool find(int u) {
	for (int j = head[u]; j; j = e[j].next) {
		int v = e[j].v;
		if (!vis[v]) {
			vis[v] = true;
			if (mat[v] == 0 || find(mat[v])) {
				//如果v这个同学没匹配 || 踹掉v匹配的课程
				mat[v] = u;
				return true; //匹配成功 
			}
		}
	}
	return false;
} 
int main() {
	scanf("%d", &t);
	while (t--) {
		len = 1;
		memset(head, 0, sizeof(head)); //初始化边 
		memset(mat, 0, sizeof(mat));
		scanf("%d%d", &p, &n); //p个课程 n个学生
		for (int u = 1; u <= p; u++) {
			scanf("%d", &k);
			for (int j = 1; j <= k; j++) {
				scanf("%d", &v);
				//代表这个课程指向这个学生
				add(u, v); 
			}
		} 
		int ans = 0;
		//找出课程能够匹配的最大量
		for (int i = 1; i <= p; i++) {
			memset(vis, false, sizeof(vis));  
			if (find(i)) ans++; //匹配成功一门课程 
		} 
		if (ans == p) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}
发布了343 篇原创文章 · 获赞 244 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/103926024