1B Lake Counting

题目来源
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

  • Line 1: The number of ponds in Farmer John’s field.

    Sample Input
    10 12
    W........WW.
    .WWW.....WWW
    ....WW...WW.
    .........WW.
    .........W..
    ..W......W..
    .W.W.....WW.
    W.W.W.....W.
    .W.W......W.
    ..W.......W.
    

    Sample Output
    3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

题意

由于最近的降雨,在农夫约翰田地的不同地方积聚了水,用N x M(1 <= N <= 100; 1 <= M <= 100)正方形的矩形表示。 每个方格包含水(‘W’)或旱地(’.’)。 农夫约翰想弄清楚他的田地里形成了多少个池塘。 池塘是一组相连的正方形,里面有水,其中一个正方形被认为与八个池塘相邻。

给定农夫约翰的田野图,确定他有多少个池塘。

解法

一道简单的dfs题目, 找到一个W, 并把与其相连的水池标记,ans+1, 重复操作即可

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n, m;
char map[111][111];
int dir[8][2] = {1,0, 0,1, -1,0, 0,-1, 1,1, 1,-1, -1,1, -1,-1};
bool vis[111][111];
int ans = 0;

void dfs(int x, int y)
{
	int tx, ty;	
	
	if(map[x][y]=='.')
		return ;	
	else
	{
		for(int i=0; i<8; ++i)
		{
			tx = x + dir[i][0];
			ty = y + dir[i][1];
			if(vis[tx][ty] == 1 || map[tx][ty]=='.')
				continue;
			else
			{
				vis[tx][ty] = 1;
				dfs(tx, ty);
			}
		}
	}
}

int main()
{
	memset(map, '.', sizeof(map));

	cin >> n >> m;
	for(int i=1; i<=n; ++i)
	{
		for(int j=1; j<=m; ++j)
			cin >> map[i][j];
	}

	for(int i=1; i<=n; ++i)
	{
		for(int j=1; j<=m; ++j)
		{	
			if(vis[i][j] == 1)
				continue;
			if(map[i][j]=='W') 
			{
				ans++;
				vis[i][j] = 1;
				dfs(i, j);
			}
		}
	}
	cout << ans << endl;
	
	return 0;
} 
发布了14 篇原创文章 · 获赞 0 · 访问量 155

猜你喜欢

转载自blog.csdn.net/loaf_/article/details/103959407