【CodeForces 1277B --- Make Them Odd】

【CodeForces 1277B --- Make Them Odd】

题目来源:点击进入【CodeForces 1277B — Make Them Odd】

Description

There are n positive integers a1,a2,…,an. For the one move you can choose any even value c and divide by two all elements that equal c.

For example, if a=[6,8,12,6,3,12] and you choose c=6, and a is transformed into a=[3,8,12,3,3,12] after the move.

You need to find the minimal number of moves for transforming a to an array of only odd integers (each element shouldn’t be divisible by 2).

Input

The first line of the input contains one integer t (1≤t≤104) — the number of test cases in the input. Then t test cases follow.

The first line of a test case contains n (1≤n≤2⋅105) — the number of integers in the sequence a. The second line contains positive integers a1,a2,…,an (1≤ai≤109).

The sum of n for all test cases in the input doesn’t exceed 2⋅105.

Output

For t test cases print the answers in the order of test cases in the input. The answer for the test case is the minimal number of moves needed to make all numbers in the test case odd (i.e. not divisible by 2).

Sample Input

4
6
40 6 40 3 20 1
1
1024
4
2 4 8 16
3
3 1 7

Sample Output

4
10
4
0

Note

In the first test case of the example, the optimal sequence of moves can be as follows:

before making moves a=[40,6,40,3,20,1];
choose c=6;
now a=[40,3,40,3,20,1];
choose c=40;
now a=[20,3,20,3,20,1];
choose c=20;
now a=[10,3,10,3,10,1];
choose c=10;
now a=[5,3,5,3,5,1] — all numbers are odd.
Thus, all numbers became odd after 4 moves. In 3 or fewer moves, you cannot make them all odd.

AC代码:

#include <bits/stdc++.h>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
using ll = long long;

int main()
{
    SIS;
    int T;
    cin >> T;
    while(T--)
    {
        int n,m=0,x,ans=0;
        cin >> n;
        set<int> s;
        for(int i=0;i<n;i++)
        {
            cin >> x;
            if(x&1) continue;
            s.insert(x);
        }
        while(!s.empty())
        {
            ans++;
            x=*s.rbegin();
            s.erase(x);
            x>>=1;
            if(x&1) continue;
            s.insert(x);
        }
        cout << ans << endl;
    }
    return 0;
}
发布了361 篇原创文章 · 获赞 127 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/103572397
今日推荐