poj - 2259 Team Queue

题目链接:https://vjudge.net/problem/POJ-2259

题目描述:

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.
Finally, a list of commands follows. There are three different kinds of commands:
  • ENQUEUE x - enter element x into the team queue
  • DEQUEUE - process the first element and remove it from the queue
  • STOP - end of test case

The input will be terminated by a value of 0 for t.
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

  这个题显然是用队列做的,但是单纯的线性队列无法解决这个问题,因为要涉及到插队问题,所以我们要用一个二维的队列来存储完成入队和出队
操作,但是这样的话,我们无法得知每个队伍的先后顺序,所以我们还需要再用一个线性队列来存储顺序
#pragma G++ optimize(2)
#include<set>
#include<map>
#include<stack>
#include<queue>
#include<cmath>
#include<stdio.h>
#include<cctype>
#include<string>
#include<vector>
#include<climits>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#define endl '\n'
#define max(a, b) (a > b ? a : b)
#define min(a, b) (a < b ? a : b)
#define mst(a) memset(a, 0, sizeof(a))
#define _test printf("~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\n")
using namespace std;
typedef long long ll;
typedef pair<int, int> P;
const double eps = 1e-7;
const int INF = 0x3f3f3f3f;
const ll ll_INF = 0x3f3f3f3f3f3f3f;
const int maxn = 1e3 + 10;
queue<int> q[maxn], clears[maxn], mark, mclears; 
vector<int> teams[maxn];
typedef vector<int>::iterator it;
int main(void) {
    //std::ios::sync_with_stdio(false);
    int t;
    while(~scanf("%d", &t) && t) {
        static int cnt = 0;
        printf("Scenario #%d\n", ++cnt);
        int tt = t;
        int kase = 0;
        while(tt--) {
            int n;
            scanf("%d", &n);
            while(n--) {
                int num;
                scanf("%d", &num);
                teams[kase].push_back(num); //存储各个队伍信息
            }
            ++kase;
        }
        char str[10];
        while(scanf("%s", str)) {
            if (str[0] == 'E') { //模拟入队
                int num;
                scanf("%d", &num);
                for (int i = 0; i<t; ++i)
                    if (num <= *(teams[i].end()-1) && num >= *(teams[i].begin())) { //寻找入队元素所在的队伍
                        if (q[i].empty()) //如果是某个队伍的第一个成员入队, 记录一下入队顺序
                            mark.push(i);
                        q[i].push(num); //模拟插队
                    } 
            }
            else if (str[0] == 'D') { //模拟出队
                printf("%d\n", q[mark.front()].front());
                q[mark.front()].pop();
                if (q[mark.front()].empty())
                    mark.pop();
            }
            else 
                break;
        }
        putchar(endl);
        //以下全是初始化
        for (int i = 0; i<t; ++i)
            q[i] = clears[i];
        mark = mclears;
        for (int i = 0; i<t; ++i)
            teams[i].clear();
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/shuitiangong/p/12210483.html