D-City HDU - 4496--------并查集+逆向思维

Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4
Sample Output
1
1
1
2
2
2
2
3
4
5

Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there’s only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

题意:
给出一个有N(0<N<=10000)个顶点的无向图,然后依次给出它的M(0<M<=100000)条边,要求依次输出当删除给出的前k(0<K<=M)条边后,该图的连通分量总数。



解析:
逆向思维。我们可以从后往前建边,因为从最后开始正好有n个联通分量。每个点都当作一个集合,当边相连就合并起来。随着建边联通分量会越来越少


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e6+100;
int fa[N];
int ans[N];
int n,m;
struct node
{
	int a,b;
}a[N];
int find(int x)
{
	if(x!=fa[x]) return fa[x]=find(fa[x]);
	return fa[x];
}
int main()
{
	while(~scanf("%d %d",&n,&m))
	{
		memset(ans,0,sizeof ans);
	for(int i=0;i<n;i++) fa[i]=i;
	for(int i=1;i<=m;i++) scanf("%d %d",&a[i].a,&a[i].b);
	int sum=n;
	for(int i=m;i>=1;i--)
	{
		ans[i]=sum;
		int x=find(a[i].a);
		int y=find(a[i].b);
		if(x!=y)
		{
			sum--;
		
			fa[x]=y;
		}
	}
	for(int i=1;i<=m;i++) printf("%d\n",ans[i]);
	}
}
发布了284 篇原创文章 · 获赞 6 · 访问量 3780

猜你喜欢

转载自blog.csdn.net/qq_43690454/article/details/104034487