pat a1076 微博转发人数_广搜

一、问题描述

1076 Forwards on Weibo (30分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

在微博中,每个用户都可能被若干个其他用户关注。而当该用户发布一条信息时,他的关注者就可以看到这条信息并选择是否转发它,且转发的信息也可以被转发者的关注者再次转发,但同一用户最多只转发该信息一次(信息的最初发布者不会转发该信息)。现在给出N个用户的关注情况(即他们各自关注了哪些用户)以及一个转发层数上限L,并给出最初发布消息的用户编号,求在转发层数上限内消息最多会被多少用户转发。

二、算法实现

#include<cstdio> 
#include<cstring>
#include<vector>
#include<queue>
using namespace std;

const int maxv=1010;

struct Node
{
	int id;
	int layer;
};

vector<Node> adj[maxv];
bool inq[maxv]={false};

int BFS(int s,int L)
{
	int numForward=0;
	queue<Node> q;
	Node start;
	start.id=s;
	start.layer=0;
	q.push(start);
	inq[start.id]=true;
	while(!q.empty())
	{
		Node topNode=q.front();
		q.pop();
		int u=topNode.id;
		for(int i=0;i<adj[u].size();i++)
		{
			Node next=adj[u][i];
			next.layer=topNode.layer+1;
			//未加入过队列,且层次不超过L 
			if(inq[next.id]==false&&next.layer<=L)
			{
				q.push(next);
				inq[next.id]=true;
				numForward++;
			}			
		}
	}	
	return numForward;
}

int main()
{
	Node user;
	int n,L,numFollow,idFollow;
	scanf("%d%d",&n,&L);  //节点个数,层次上限 
	for(int i=1;i<=n;i++)
	{
		user.id=i;
		scanf("%d",&numFollow);
		for(int j=0;j<numFollow;j++)
		{
			scanf("%d",&idFollow);
			adj[idFollow].push_back(user);
		}
	}
	int numQuery,s;
	scanf("%d",&numQuery);
	for(int i=0;i<numQuery;i++)
	{
		memset(inq,false,sizeof(inq));
		scanf("%d",&s);
		int numForward=BFS(s,L);
		printf("%d\n",numForward);		
	}
	return 0;
}
发布了180 篇原创文章 · 获赞 64 · 访问量 15万+

猜你喜欢

转载自blog.csdn.net/OpenStack_/article/details/104077819