The Unique MST

 The Unique MST
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!






次二小生成树的应用,先求最小生成树, 然后枚举删除的边,再求最小生成树
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct edge {
	int p1, p2, cost;
}e[200002];//开大一点,避免Runtime Error 
int f[10005],n, m, flag, mst;
int find(int x)
{
	if(x == f[x])
		return x;
	else 
		return f[x] = find(f[x]);
}
bool cmp(edge a, edge b)//权由小到大排一次 
{
	return a.cost < b.cost;
}
void init()
{
	for(int i = 0; i <= m; i++)
		f[i] = i;
}
void MST()
{
	int j, i, cnt = 0, x, y, temp, ans, num[10005],k;
	init();
	for(mst = 0,i = 0; i < m; i++)
	{
		x = find(e[i].p1);
		y = find(e[i].p2);
		if(x != y)
		{
			f[x] = y;
			mst+= e[i].cost;
			num[cnt++] = i;
		}	
	}
	flag = 1;
	for(k = 0; k < cnt; k++)// 
	{
		init();
		ans = 0,temp = 0;
		for(i = 0; i < m; i++)
		{
			if(i == num[k])
				continue;
			x = find(e[i].p1);
			y = find(e[i].p2);
			if(x != y){
				f[x] = y;
				ans+= e[i].cost;
				temp++;
			}
		}
		if(temp != cnt)
			continue;
		if(ans == mst)
		{	
			flag = 0;
			return;
		}
	}
}
int main()
{
	int i,j,test;
	scanf("%d",&test);
	while(test--)
	{
		scanf("%d %d",&n, &m);
		for(i = 0; i < m; i++) 
			scanf("%d %d %d",&e[i].p1, &e[i].p2, &e[i].cost);	
		sort(e, e + m, cmp);
		MST();
		if(flag)
			printf("%d\n",mst);
		else 
			printf("Not Unique!\n");
	}
}


猜你喜欢

转载自blog.csdn.net/u013780740/article/details/38236569