PAT甲级1046

1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7
#include<bits/stdc++.h>
using namespace std;
const int Max = 100010;

int main(){
	int n, x, dis[Max];
	scanf("%d", &n);
	fill(dis, dis + Max, 0);
	for(int i = 1; i <= n; i++){
		scanf("%d", &x);
		dis[i] = dis[i - 1] + x;
	}
	int m;
	scanf("%d", &m);
	int start, end;
	for(int i = 0; i < m; i++){
		scanf("%d %d", &start, &end);
		if(start > end)
		swap(start, end);
		int a = dis[end - 1] - dis[start - 1];
		int b = dis[n] - a;
		x = min(a, b);
		printf("%d\n", x);
	}
}
发布了116 篇原创文章 · 获赞 7 · 访问量 6019

猜你喜欢

转载自blog.csdn.net/qq_40204582/article/details/87204026