逃离迷宫

逃离迷宫

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27482    Accepted Submission(s): 6750


Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。
 

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input
 
  
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 

Sample Output
 
  
no yes
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1253  1175  1072  1026  1180 

解题思路:
利用BFS进行搜索
 
  
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
char str[105][105];
int id[105][105];
int n,m;
int k,x1,y5,x2,y2;
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
int flag;

struct node
{
    int x,y,k;
};

void bfs()
{
    node t;
    t.x=x1;
    t.y=y5;
    t.k=-1;
    id[x1][y5]=1;
    queue<node> q;
    q.push(t);
    while(!q.empty())
    {
        node t1;
        t1=q.front();
        q.pop();
        if(t1.x==x2&&t1.y==y2&&t1.k<=k)
        {
            flag=true;
        }

        for(int i=0;i<4;i++)
        {
            node t2;
            t2.x=t1.x+dir[i][0];
            t2.y=t1.y+dir[i][1];
            while(t2.x>=1&&t2.x<=n&&t2.y>=1&&t2.y<=m&&str[t2.x][t2.y]!='*')
            {

                if(id[t2.x][t2.y]==0)
                {
                    t2.k=t1.k+1;
                    id[t2.x][t2.y]=1;
                    q.push(t2);
                }
                node t3;
                t3.x=t2.x+dir[i][0];
                t3.y=t2.y+dir[i][1];
                t2=t3;
            }
        }
    }
}

int main()
{
    int T;
    cin >> T;
    while(T--)
    {
        cin >> n >> m;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf(" %c",&str[i][j]);
            }
        }
        memset(id,0,sizeof(id));
        scanf("%d%d%d%d%d",&k,&y5,&x1,&y2,&x2);
        flag=false;
        bfs();
        if(flag==true)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/qq_36979930/article/details/75196146
今日推荐