B OOXX Game(FZU 2151)

           B  OOXX Game

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with two symbol “O” or “X”. Then they take turns to choose a grid with symbol “O” and change it into “X”. The game ends when all the symbols in the board are “X”, and the one who cannot play in his (her) turns loses the game. Fat brother and Maze like this kind of OOXX game very much and play it day and night. They don’t even need a little rest after each game!

Here's the problem: Who will win the game if both use the best strategy? You can assume that Maze always goes first.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the state of the board.

1 <= T <=100, 1 <= n <=100, 1 <= m <=100

Output

For each case, output the case number first, and then output the winner’s name, either Fat brother or Maze. See the sample input and output for more details.

Sample Input
3
1 4
OXXX
2 4
OOXX
OOXX
1 2
XX
Sample Output
Case 1: Maze
Case 2: Fat brother
Case 3: Fat brother
 
 
 
 
题目的大概意思是有两个人在玩游戏,把‘O’改成‘X’,最后一改的人胜利,默认为每次从Maze开始。
直接判断‘O’的个数就行了,如果是奇数Maze胜利,偶数就Fat brother胜利。
 
 
代码如下:
 
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[1005][1005];
int main()
{
    int t,k=1;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        int n,m,ans=0;
        scanf("%d%d",&n,&m);
        getchar();
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j]=='O')
                    ans++;
            }
            getchar();
        }
        printf("Case %d: ",k++);
        if(ans%2==1)
            printf("Maze\n");
        else
            printf("Fat brother\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/78633879