1099 Build A Binary Search Tree (30分)/二叉搜索树/二叉树遍历

题目描述

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NNN (≤100\le 100100) which is the total number of nodes in the tree. The next NNN lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1N-1N1, and 0 is always the root. If one child is missing, then −1-11 will represent the NULL child pointer. Finally NNN distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

结论

对二叉搜索树的进行中序遍历,结点的key值构成的中序序列,该序列是从小到大的排列。


思路

利用上述结论,可以很快地形成思路,用结构体存结点左孩子left、右孩子right在数组中的下标,数据域val存值。先对序列排序,对二叉树进行中序遍历,遍历过程中依次将序列的值赋给结构体数据域val,然后进行层序遍历即可。

AC代码

#include<iostream>
#include<string>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
struct node {
	int left, right, val;
}no[100];
int v[100],t;
void inorder(int i) {
	if (no[i].left == -1 && no[i].right == -1) {
		no[i].val = v[t++];
		return;
	}
	if (no[i].left != -1) inorder(no[i].left);
	no[i].val = v[t++];
	if (no[i].right != -1) inorder(no[i].right);
}
int main() {
#ifdef ONLINE_JUDGE
#else
	freopen("1.txt", "r", stdin);
#endif
	int n; cin >> n;
	for (int i = 0; i < n; i++) {
		scanf("%d %d", &no[i].left, &no[i].right);
	}
	for (int i = 0; i < n; i++) {
		scanf("%d", &v[i]);
	}
	sort(v, v + n);
	inorder(0);
	queue<int> q;  //将下标入队即可
	q.push(0);
	while (!q.empty()) {
		int now = q.front();
		q.pop();
		if (now != 0) printf(" ");
		printf("%d", no[now].val);
		if (no[now].left != -1) q.push(no[now].left);
		if (no[now].right != -1) q.push(no[now].right);
	}
	return 0;
}
发布了62 篇原创文章 · 获赞 7 · 访问量 3108

猜你喜欢

转载自blog.csdn.net/weixin_43590232/article/details/104213909