杭电oj 1018

杭州电子科技大学 online judge 1018

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20
Sample Output
7
19
Source
Asia 2002, Dhaka (Bengal)

个人思路:
1.确定输入次数num
2.阶乘位数算法:首先采用斯特拉公式近似,其次,采用大数求位数的方法计算

主要公式:
1.斯特拉公式
在这里插入图片描述
2.整数求位数常用方法
digits = log10(n) + 1 ;//n表示该整数,digits表示位数

代码

#include<iostream>
#include<string> 
#include<cmath>
#define PI 3.141592654
#define E 2.71828182846
using namespace std;
int stl(int n)
{
    int s=1;
    if(n>3)
           //斯特拉公式如图 
           //一个大数求位数的方法:log10(n)+1
   s = int(log10(2*PI*n)/2+n*log10(n/E)+1); 
    return s;
}
int main()
{
 int num,t;
 cin>>num;
 for(int i = 0;i<num;i++){
     cin>>t;
     cout<<stl(t)<<endl;
 }
    return 0;
}
 
发布了5 篇原创文章 · 获赞 0 · 访问量 63

猜你喜欢

转载自blog.csdn.net/MARSHCW/article/details/104229474