E-Convex【暑假训练赛5】

Description

We have a special convex that all points have the same distance to origin point.
As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.
Now give you the data about the angle, please calculate the area of the convex

Input

There are multiple test cases.
The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)
The next lines contain N integers indicating the angles. The sum of the N numbers is always 360.

Output

For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.

Sample Input

4 1
90 90 90 90
6 1
60 60 60 60 60 60

Sample Output

2.000
2.598

Code

//求n个腰长为d,顶角已知的等腰三角形面积
#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
const float pi=3.14159;  //精度把握一下
float angle[15];

int main(){
    int n,d;
    while(~scanf("%d%d",&n,&d)){
        for(int i=0;i<n;i++){
            scanf("%f",&angle[i]);
            getchar();
        }
        float area=0;
        for(int i=0;i<n;i++){
            area+=(d*d*sin(angle[i]*pi/180))/2;  //正弦函数的用法,弧度
        }
        printf("%.3f\n",area);
    }
    return 0;
}
发布了25 篇原创文章 · 获赞 5 · 访问量 1675

猜你喜欢

转载自blog.csdn.net/qq_43611144/article/details/99099649