zzulioj1132(数字字符的数目)

题目描述
对于给定的一个字符串,统计其中数字字符出现的次数。字符串长度不超过1000.

输入
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

输出
对于每个测试实例,输出该串中数字字符的个数,每个输出占一行。

样例输入
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

样例输出
6
9

#include<stdio.h>
#include<string.h>//与字符串操作相关
int main(){
	int n, c, i, x;
	char a[1000], ch;
	scanf("%d", &n);
	while (n--){//n组测试
		c = 0;
		scanf("%s", a);
		x = strlen(a);//长度
		for (i = 0; i <= x - 1; i++)
		{
			if (a[i] >= '0'&&a[i] <= '9')c++;
		}
		printf("%d\n", c);
	}
	return 0;
}

发布了16 篇原创文章 · 获赞 0 · 访问量 343

猜你喜欢

转载自blog.csdn.net/m0_46238735/article/details/104387937