PTAj甲级真题1019General Palindromic Number

1019 General Palindromic Number (20分)

首先,先贴柳神的博客

https://www.liuchuo.net/archives/2055 这是地址

想要刷好PTA,强烈推荐柳神的博客,和算法笔记

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits *a**i* as ∑i=0k(aibi). Here, as usual, 0≤ai<b for all i and *a**k* is non-zero. Then N is palindromic if and only if ai=aki for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "*a**k* *a**k−1 ... a*0". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2  

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5    

Sample Output 2:

No
4 4 1

生词

General 生词

Palindromic 回文结构

decimal 小数点,小数

notation 符号

题目大意

给两个数,要你把第一个数转换成第二个数的进制,然后判断转换出来的数,是不是一个回文数

注意点

① 转换的进制是可以超过10的,因此我们存储的时候最好不要用字符数组

例如 31 20最后输出的时候就要输出

No
1 11

要将1和11比较

下面是我参考了柳神的代码之后改的代码

#include<iostream>
#include<cmath>
using namespace std;
int main(void) {
    int N, b, A[34], index = 0;
    cin >> N >> b;
    while (N) {
        A[index++] = N % b;
        N = N / b;
    }
    int flag = 0;
    for(int i=0;i<index/2;i++)
        if (A[i] != A[index - i - 1]) { flag = 1; break; }

    if (flag == 0)  cout << "Yes" << endl;
    else    cout << "No" << endl;

    for (int j =index-1; j >= 0; j--) {
        if (j != index-1)   cout << ' ';
        cout << A[j];
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/a-small-Trainee/p/12359570.html