POJ2352-树状数组

Stars

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 55219   Accepted: 23729

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

扫描二维码关注公众号,回复: 9513863 查看本文章
1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999

题目意思是输入n个坐标,每个点左下有多少个点就表示几级,然后输出从0到n-1级的个数

思路:用树状数组做,因为输入的数据已经对y排好了序,所以我们只需要对x搞事就行了

坑点:输入数据有0,树状数组不会考虑0的情况,在进行更新的时候要+1

代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=15000+1000;
const int MAXN=32000+1000;
int num[MAXN],ans[maxn];
int lowbit(int x)
{
    return x&(-x);
}
void add(int x,int val)
{
    while (x<=MAXN)
        {
            num[x]=num[x]+val;
            x=x+lowbit(x);
        }
    return ;
}
int query(int x)
{
    int sum=0;
    while (x>0)
        {
            sum=sum+num[x];
            x=x-lowbit(x);
        }
    return sum;
}
int main()
{
    int i,n,m,y,sum;
    while (scanf("%d",&n)!=EOF)
        {
            memset(ans,0,sizeof(ans));
            memset(num,0,sizeof(num));
            for (i=1;i<=n;i++)
                {
                    scanf("%d%d",&m,&y);
                    sum=query(m+1);      //sum表示几级的
                    ans[sum]++;          //几级的个数,考虑到没有0的情况,
                    add(m+1,1);         //更新,因为y坐标是递增的,所以后面的数据的y都比前面的大
                }
            for (i=0;i<n;i++)
                cout<<ans[i]<<endl;
        }
    return 0;

发布了46 篇原创文章 · 获赞 2 · 访问量 3221

猜你喜欢

转载自blog.csdn.net/z1164754004z/article/details/82911163