1085 Perfect Sequence (25分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and mare the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8
#include <bits/stdc++.h>

#define ll long long
using namespace std;
ll n,p,ar[100005],m=0;

int main(){
    scanf("%lld %lld",&n,&p);
    for(int i=0;i<n;i++)scanf("%lld",&ar[i]);
    sort(ar,ar+n);
    for(int i=0;i<n;i++){
        ll t = ar[i]*p;
        ll pos = upper_bound(ar+i, ar+n, t)-(ar+i);
        if(pos>m)m=pos;
    }
    cout<<m;
    return 0;
}
发布了403 篇原创文章 · 获赞 48 · 访问量 10万+

猜你喜欢

转载自blog.csdn.net/lannister_awalys_pay/article/details/104306925