PAT-1116 Come on! Let's C (20 分)(素数判定)

1116 Come on! Let's C (20 分)

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
  • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​4​​), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

思路

水题

代码 

#include<cstdio>
#include<algorithm>
#include<cstring>

using namespace std;

const int maxn = 10000 + 100;
int a[maxn];

bool is_prime(int p){
	if (p == 1)return false;
	if (p == 2)return true;
	for (int i = 2; i*i <= p ; i++){
		if (p%i == 0)return false;
	}
	return true;
}

int main(){
	int n, t, k;
	scanf("%d", &n);
	memset(a, -1, sizeof(a));
	
	for (int i = 1; i <= n; i++) {
		scanf("%d", &t);
		if (i == 1) {
			a[t] = 1;
			continue;	
		}
		if (is_prime(i)) a[t] = 2;
		else a[t] = 3;
	}
	
	scanf("%d", &k);
	for (int i = 0; i < k; i++) {
		scanf("%d", &t);
		if (a[t] == -1) {
			printf("%04d: Are you kidding?\n", t);
		} else {
			if(a[t] == 1) {
				printf("%04d: Mystery Award\n", t);
			} else if(a[t] == 2) {
				printf("%04d: Minion\n", t);
			} else if(a[t] == 3) {
				printf("%04d: Chocolate\n", t);
			} else if(a[t] == 4) {
				printf("%04d: Checked\n", t);
			}
			a[t] = 4;
		}
	}
	return 0;
}
发布了148 篇原创文章 · 获赞 52 · 访问量 24万+

猜你喜欢

转载自blog.csdn.net/m0_38072683/article/details/95071383