POJ 2955 括号匹配

 
Brackets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17416   Accepted: 9016

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1< i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
#include<stdio.h>
#include<string.h>
#define maxn 110
int dp[maxn][maxn];

int max(int x,int y){
	return x>y?x:y;
}
int main(){
	char s[maxn];
	while(scanf("%s",s)!=EOF){
		int i,j,k,len,n;
		if(s[0]=='e') break;
		memset(dp,0,sizeof(dp));
		n=strlen(s);
		for(len=1;len<=n;len++){
			for(i=0;i<n;i++){
				j=len+i-1;
				//if(s[i]==')'||s[i]==']')
					dp[i][j]=dp[i+1][j];   //第i个在这段区间没有匹配
				//else
					for(k=i+1;k<=j;k++){    //第i个与第k个位置匹配上时,状态如下
						if((s[k]==')'&&s[i]=='(')||(s[k]==']'&&s[i]=='['))
							dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2);
				}
			}
		}
		printf("%d\n",dp[0][n-1]);
	}
	return 0;
}
发布了72 篇原创文章 · 获赞 3 · 访问量 1841

猜你喜欢

转载自blog.csdn.net/vivi_cin/article/details/104877578