2017中国大学生程序设计竞赛 - 女生专场(Graph Theory)

Graph Theory

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1796    Accepted Submission(s): 750


Problem Description
Little Q loves playing with different kinds of graphs very much. One day he thought about an interesting category of graphs called ``Cool Graph'', which are generated in the following way:
Let the set of vertices be {1, 2, 3, ..., n }. You have to consider every vertice from left to right (i.e. from vertice 2 to n ). At vertice i , you must make one of the following two decisions:
(1) Add edges between this vertex and all the previous vertices (i.e. from vertex 1 to i1 ).
(2) Not add any edge between this vertex and any of the previous vertices.
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices. A perfect matching is a matching that each vertice is covered by an edge in the set.
Now Little Q is interested in checking whether a ''Cool Graph'' has perfect matching. Please write a program to help him.
 
Input
The first line of the input contains an integer T(1T50) , denoting the number of test cases.
In each test case, there is an integer n(2n100000) in the first line, denoting the number of vertices of the graph.
The following line contains n1 integers a2,a3,...,an(1ai2) , denoting the decision on each vertice.
 
Output
For each test case, output a string in the first line. If the graph has perfect matching, output ''Yes'', otherwise output ''No''.
 
Sample Input
3 2 1 2 2 4 1 1 2
 
Sample Output
Yes No No
 
Source
 
Recommend
jiangzijing2015   |   We have carefully selected several similar problems for you:   6286  6285  6284  6283  6282 
题意:给n个顶点,从第一个点开始操作,每个点有两种操作:1、将当前结点和之前的所有结点都加一条边 2、当前结点与之前的所有结点都不加边。问是否能够完美匹配?完美匹配是指所有的结点都有边连接,并且这些边中没有公共的顶点。
 
每一个2后面必须至少有一个1,那么倒着遍历
 
#include <iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<deque>
#include<vector>
#define ll long long
#define inf 0x3f3f3f3f
#define mod 1000000007;
using namespace std;
int a[100005];
int main()
{
   int T;
   scanf("%d",&T);
   while(T--)
   {
       int n;
       scanf("%d",&n);
       int s1=0;
       int s2=0;
       int x;
       bool f=1;
       for(int i=2;i<=n;i++)
       {//2只能靠后面的1把它连上边

           scanf("%d",&x);
           a[i]=x;
       }
       for(int i=n;i>=2;i--)//倒着遍历,从后往前看的话,1的数量一定要比2多
       {
           if(a[i]==1) s1++;
           else s2++;
           if(s2>s1)
           {
               f=0;
               break;
           }
       }
       if(n%2==1||!f||x!=1) printf("No\n");//奇数个点肯定不行
       else printf("Yes\n");
   }
   return 0;
}

猜你喜欢

转载自www.cnblogs.com/caiyishuai/p/9073702.html
今日推荐