HDu3729最大匹配

After this year’s college-entrance exam, the teacher did a survey in his class on students’ score. There are n students in the class. The students didn’t want to tell their teacher their exact score; they only told their teacher their rank in the province (in the form of intervals).

After asking all the students, the teacher found that some students didn’t tell the truth. For example, Student1 said he was between 5004th and 5005th, Student2 said he was between 5005th and 5006th, Student3 said he was between 5004th and 5006th, Student4 said he was between 5004th and 5006th, too. This situation is obviously impossible. So at least one told a lie. Because the teacher thinks most of his students are honest, he wants to know how many students told the truth at most.
InputThere is an integer in the first line, represents the number of cases (at most 100 cases). In the first line of every case, an integer n (n <= 60) represents the number of students. In the next n lines of every case, there are 2 numbers in each line, X i and Y i (1 <= X i <= Y i <= 100000), means the i-th student’s rank is between X i and Y i, inclusive.

OutputOutput 2 lines for every case. Output a single number in the first line, which means the number of students who told the truth at most. In the second line, output the students who tell the truth, separated by a space. Please note that there are no spaces at the head or tail of each line. If there are more than one way, output the list with maximum lexicographic. (In the example above, 1 2 3;1 2 4;1 3 4;2 3 4 are all OK, and 2 3 4 with maximum lexicographic)Sample Input
2
4
5004 5005
5005 5006
5004 5006
5004 5006
7
4 5
2 3
1 2
2 2
4 4
2 3
3 4
Sample Output

32 3 451 3 5 6 7




题意: n个人每个人可以在x~y(输入)之间选择一个数(该数被选择后就不能被其他人选择了),问最多有多少个人能选择到数,输出选择最多人的情况中字典树最大的情况。


思路:
         每个人对应到x~y之间有联系,形成二部图;求1~100000中与人的最大匹配,由于字典树最大,所以遍历的时候从大到小就可以了。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define LL long long
template<class T>
LL max(T a,T b)
{
	return a>b?a:b;
 } 
 template<class T>
 LL min(T a, T b)
 {
 	return a<b?a:b;
 }
 const int MAX=105;
 LL n; 
 bool vism[100005];
 LL linked[100005];
 struct node {
 	int x,y;
 }edge[MAX]; 
 bool Dfs(int u)
 {
 	for(int v=edge[u].x;v<=edge[u].y;v++)
 	{
 		if(!vism[v])
 		{
 			vism[v]=1;
 			if(linked[v]==-1||Dfs(linked[v]))
 			{
 				linked[v]=u;
 				return 1;
			 }
		 }
	 }
	 return 0;
 }
 void Find()
 {
 	LL hones[MAX];
 	LL cnt=0;
 	for(int i=n;i>=1;i--)
 	{
 		memset(vism,0,sizeof(vism));
 		if(Dfs(i))
 		hones[cnt++]=i;
	 }
	 
	  std::sort(hones,hones+cnt);
	  printf("%lld\n",cnt);
	  for(int i=0;i<cnt;i++)
	  {
	  	if(i==0) printf("%lld",hones[i]);
	  	else printf(" %lld",hones[i]);
	  }
	  printf("\n");
 }
 int main()
 {
 	int T;
 	scanf("%d",&T);
 	while(T--)
 	{
 		scanf("%lld",&n);
 		for(int i=1;i<=n;i++)
 		{
 			scanf("%d%d",&edge[i].x,&edge[i].y);
 		//	map[b][a]=1;
		 }
		 memset(linked,-1,sizeof(linked));
		 Find();
	 }
 	return 0;
 }




发布了46 篇原创文章 · 获赞 43 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/wangxiaai/article/details/76695444