E - Aggressive cows

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance? Input
* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9
Sample Output
3
Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.


      思路:最大的最小值,直接就是二分法,重点的就是二分法的范围,因为每次进行判断的时候,如果符合则[x+1,w],不符则 
                [x,w-1]。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int cow[100005];
int judge(int n,int b,int a)
{
    int sum=1,d=0;
    for(int i=1; i<a; i++)
    {
        if(cow[i]-cow[d]>=n)
        {
            sum++;
            d=i;
        }
    }
    if(sum>=b)
        return 1;
    else
        return 0;
}
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)==2)
    {
        for(int i=0; i<a; i++)
            scanf("%d",&cow[i]);
        sort(cow,cow+a);
        int x,q=0,w=cow[a-1]-cow[0];
        while(w>=q)
        {
            x=(w+q)/2;
            if(judge(x,b,a))
                q=x+1;
            else
                w=x-1;
        }
        printf("%d\n",q-1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hnust_lec/article/details/79331135