PAT A1104 Sum of Number Segments (20分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805363914686464

题目描述
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

输入
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10^​5​​ . The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

输出
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

样例输入
4
0.1 0.2 0.3 0.4

样例输出
5.00

代码

#include <cstdio>

int main() {
	int n;
	double sum = 0, a;
	scanf("%d", &n);
	for(int i = 1; i <= n; i++) {
		scanf("%lf", &a);
		sum += a * i * (n + 1 - i);
	}
	printf("%.2f\n", sum);
	return 0;
}
发布了288 篇原创文章 · 获赞 12 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104905894
今日推荐