PAT A1067 Sort with Swap(0, i) (25分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805403651522560

题目描述
Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

输入
Each input file contains one test case, which gives a positive N (≤10^​5​​ ) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

输出
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

样例输入
10
3 5 7 2 6 4 9 0 8 1

样例输出
9

代码

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 100010;
int pos[maxn];

int main() {
	int n, ans = 0;
	scanf("%d", &n);
	int left = n - 1, num;
	for(int i = 0; i < n; i++) {
		scanf("%d", &num);
		pos[num] = i;
		if(num == i && num != 0) {
			left--;
		}
	}
	int k = 1;
	while(left > 0) {
		if(pos[0] == 0) {
			while(k < n) {
				if(pos[k] != k) {
					swap(pos[0], pos[k]);
					ans++;
					break;
				}
				k++;
			}
		}
		while(pos[0] != 0) {
			swap(pos[0], pos[pos[0]]);
			ans++;
			left--;
		}
	}
	printf("%d\n", ans);
	return 0;
}
发布了288 篇原创文章 · 获赞 12 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104743151