字符串哈希 acwing 841

给定一个长度为n的字符串,再给定m个询问,每个询问包含四个整数l1,r1,l2,r2,请你判断[l1,r1]和[l2,r2]这两个区间所包含的字符串子串是否完全相同。

字符串中只包含大小写英文字母和数字。

输入格式
第一行包含整数n和m,表示字符串长度和询问次数。

第二行包含一个长度为n的字符串,字符串中只包含大小写英文字母和数字。

接下来m行,每行包含四个整数l1,r1,l2,r2,表示一次询问所涉及的两个区间。

注意,字符串的位置从1开始编号。

输出格式

对于每个询问输出一个结果,如果两个字符串子串完全相同则输出“Yes”,否则输出“No”。

每个结果占一行。

数据范围
1≤n,m≤105

输入样例:

8 3
aabbaabb
1 3 5 7
1 3 6 8
1 2 1 2

输出样例:

Yes
No
Yes

#include <iostream>

using namespace std;

typedef unsigned long long ULL;

const int P = 131, N = 100100;

ULL p[N], a[N];

char str[N];


ULL check(int x, int y)
{
    return a[y] - a[x - 1] * p[y - x + 1];
}
int main()
{
    int n, m; cin >> n >> m;
    
    cin >> str + 1;
    
    p[0] = 1;
    
    for(int i = 1; i <= n ; i ++)
    {
        p[i] = p[i - 1] * P;
        
        a[i] = a[i - 1] * P + str[i] - '0' + 1;
    }
    while(m --)
    {
        int a, b, c, d; cin >> a >> b >> c >> d;
        
        if(check(a, b) == check(c, d))
        {
            cout << "Yes" << endl;
        }
        else 
        {
            cout << "No" << endl;
        }
    }
    return 0;
}
发布了53 篇原创文章 · 获赞 14 · 访问量 1897

猜你喜欢

转载自blog.csdn.net/weixin_45630535/article/details/104779712