HDU-1061 Rightmost Digit(快速幂取余)

Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

 

Output
For each test case, you should output the rightmost digit of N^N.
 

 

Sample Input
2
3
4
 

 

Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

#include<iostream>
using namespace std;
int cifang(long long a,long long b)
{
    int ans=1;
    int base=a%10;  //!!!!!!!
    while(b)
    {
        if(b&1)
        {
            ans=(ans*base)%10;   //!!!!!!
        }
        base=(base*base)%10;    //!!!!!!!  亲测这三个求余少一个就WA!!!!!!
        b>>=1;
    }
    return ans;
}
int main()
{
    int t;
    long long n;
    while(cin>>t)
    {
        while(t--)
        {
            cin>>n;
            cout<<cifang(n,n)%10<<endl;
        }
    }
}

猜你喜欢

转载自blog.csdn.net/asd1637579311/article/details/80066763