中序后序建立二叉树

求二叉树的先序遍历

Time Limit: 1000MS  Memory Limit: 65536KB

Problem Description

 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 

Output

 输出二叉树的先序遍历序列

Example Input

2
dbgeafc
dgebfca
lnixu
linux

Example Output

abdegcf
xnliu
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct node
{
    char data;
    struct node *lt, *rt;
};

struct node *Creat(int n, char *mid, char *last)///中序后序建立二叉树
{
    if(n==0)
        return NULL;
    struct node *root;
    root = (struct node *)malloc(sizeof(struct node ));
    root->data = last[n-1];
    int i;
    for(i=0;i<n;i++)
        if(last[n-1] == mid[i])
            break;
    root->lt = Creat(i, mid, last);
    root->rt = Creat(n-i-1, mid+i+1, last+i);

    return root;
}

///先序遍历
void pre(struct node *root)
{
    if(root)
    {
        printf("%c", root->data);
        pre(root->lt);
        pre(root->rt);
    }
}

int main()
{
    int t, len;
    scanf("%d", &t);
    while(t--)
    {
        char mid[100], last[100];
        scanf("%s%s", mid, last);
        len = strlen(mid);
        struct node *root = NULL;
        root = Creat(len, mid, last);
        pre(root);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/aqa2037299560/article/details/79243179