(种类并查集)POJ1703 Find them, Catch them

点击打开链接

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 50365   Accepted: 15464

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source


//poj 1703种类并查集
#include<iostream>
#include<cstdio>
#include<string>
#include<string.h>
using namespace std;
const int maxn=1e5+10;
int par[maxn],gang[maxn];
//用gang[]来存关系,0代表是同伙,1不是同伙
int n,m;

void init()
{
    for(int i=1;i<=n;i++)
    {
        par[i]=i;   //前驱节点
        gang[i]=0;  //这时候前驱节点数组中存的就是自己,和自己肯定是同伙呀,,,嘻嘻
    }
}

int fi(int x)
{
    if(par[x]!=x){
        int temp=par[x]; //x==4   3
        par[x]=fi(temp);  //回溯的过程,更新前驱节点    不明白的话,可以自己举个例子,在纸上画画  
        gang[x]=(gang[x]+gang[temp])%2;  //更新自己和前驱节点的关系
        return par[x];
    }
    return x;
}

void join(int x,int y)
{
    int fx=fi(x),fy=fi(y);
    if(fx!=fy){
        par[fy]=fx;
        gang[fy]=(gang[x]+gang[y]+1)%2;   //这点x,y不是同伙,具体怎么推,我是找的规律,不知道其他大佬怎么实现的啦
    }

}

int main()
{
    int t;
    char ch;
    int a,b;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        init();
        while(m--)
        {
            getchar();
            scanf("%c%d%d",&ch,&a,&b);
            if(ch=='D')
                join(a,b);
            else{
                if(fi(a)!=fi(b))
                    printf("Not sure yet.\n");
                else if(gang[a]==gang[b])
                    printf("In the same gang.\n");
                else
                    printf("In different gangs.\n");
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37275680/article/details/80108393