PTA 一元多项式求导 (水题)

7-16 一元多项式求导(20 分)

题目:https://pintia.cn/problem-sets/15/problems/820

设计函数求一元多项式的导数。

输入格式:

以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:

以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

水题不解释

要注意没有输出的情况,比如输入一个 6 0,答案就是0,应该输出0 0,这点题目没有明说结果为0应该怎么输出。而且题目不是说只输出非0项吗,这。。。

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <vector>
#include <sstream>
#include <map>
#include <queue>
#include <stack>
#include <cstring>
#include <set>
#define INF 1000000
using namespace std;

int main()
{
    int a,b;
    int first=0;
    while(scanf("%d%d",&a,&b)==2)
    {
        if(b==0) continue;
        int x=a*b;
        int y=b-1;
        if(first==0)
        {
            printf("%d %d",x,y);
            first=1;
        }
        else
        {
            printf(" %d %d",x,y);
        }
    }
    if(first==0)
    {
        printf("0 0");
    }
    printf("\n");
    return 0;
}


猜你喜欢

转载自blog.csdn.net/zl1085372438/article/details/79478882