HDU 1028 Ignatius and the Princess III(dp:方案数)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24699    Accepted Submission(s): 17069


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
 
  
4
10
20
 

Sample Output
 
  
5
42
627
和省赛物资调度题一样,dp[ i ]代表i的方案数
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
int dp[125];
void init()
{
	dp[0]=1;
	for(int i=1;i<125;i++)
	{
		for(int j=i;j<125;j++)
		dp[j]+=dp[j-i];
	}
	return ;
}
int main()
{
	int n;
	init();
	while(~scanf("%d",&n))
	{
		printf("%d\n",dp[n]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/bbhhtt/article/details/80415903