HDU 2577 How to Type(dp)

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7829    Accepted Submission(s): 3519


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
 
  
3
Pirates
HDUacm
HDUACM
 

Sample Output
 
  
8
8
8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

设a[ i ],b[ i ]两数组分别代表Caps lock关与开时打印第 i 个字母的最少操作数。同时又要分大小写两种情况考虑:

c[ i ]是小写时:

    a[i]=min(a[i-1]+1,b[i-1]+2);Caps lock关,小写直接输入+1;Caps lock开,shift +输入,共2次。

    b[i]=min(a[i-1]+2,b[i-1]+2);小写直接输入+1,同时打开Caps lock,两次; Caps lock开,shift +输入,共2次。

c[ i ]是大写时:

    a[i]=min(a[i-1]+2,b[i-1]+2);Caps lock关,shift +输入,共2次;Caps lock开,输入加关闭Caps lock,共2次。

    b[i]=min(a[i-1]+2,b[i-1]+1);打开Caps lock,再输入,两次;直接输入1次

最后要注意b数组b[ 0 ]=1 , 最开始要打开Caps lock,操作一次;b[ len ]+=1 , 最后要关闭Caps lock

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int a[105];
int b[105];
char c[105];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		b[0]=1;
		scanf("%s",c+1);
		int len=strlen(c+1);
		for(int i=1;i<=len;i++)
		{
			if(c[i]>='a'&&c[i]<='z')
			{
				a[i]=min(a[i-1]+1,b[i-1]+2);
				b[i]=min(a[i-1]+2,b[i-1]+2);
			}
			else if(c[i]>='A'&&c[i]<='Z')
			{
				a[i]=min(a[i-1]+2,b[i-1]+2);
				b[i]=min(a[i-1]+2,b[i-1]+1);
			}
		}
		b[len]++;
		if(a[len]<b[len])
		{
			printf("%d\n",a[len]);
		}
		else printf("%d\n",b[len]);
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/bbhhtt/article/details/80236692