#D - Harmonic Number (II)

I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code

long long H( int n ) {
long long res = 0;
for( int i = 1; i <= n; i++ )
res = res + n / i;
return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output
For each case, print the case number and H(n) calculated by the code.

Sample Input
11
1
2
3
4
5
6
7
8
9
10
2147483647
Sample Output
Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386
这一题是求求n/1+n/2+n/3+n/4+…+n/n的和,图像的方法没太理解,所以把每一个例子列出来找规律,以10为例,先求出值为1的项的个数为(10/1-10/2)个,分别(10/10,10/9,10/8,10/7,10/6),值为2个项的个数(10/2-10/3)分别是(10/5,10/4),在求出值为3即sqrt(10)的项的个数,最后求n/1+n/2+…+n/sqrt(n)的和,前面是有规律的,
1的个数10/1-10/2 = 5;
2的个数10/2-10/3 = 2;
3的个数10/3-10/4 = 1;而sqrt(n)计算了两次,最后减去一次。
以下是代码部分:

#include<stdio.h>
#include<math.h>
int main()
{
	int k,p=1;
	scanf("%d",k);
	while(k--)
	{
		long long n,i,l,r;
		scanf("%lld",&n);
		long long sum=0,m=sqrt(n);
		for(i=1;i<=m;++i)
		{
			sum+=n/i;
			l=n/i;
			r=n/(i+1);
			if(l>r)
			sum+=(l-r)*i;
		} 
		if(n/m==m)
		sum=sum-m;
		printf("Case %d: %lld\n",p++,sum);
	}
	return 0;
}
发布了18 篇原创文章 · 获赞 0 · 访问量 206

猜你喜欢

转载自blog.csdn.net/qq_46304792/article/details/105256713