A1046 Shortest Distance (20分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10
​5​​ ]), followed by N integer distances D​1D​2​​ ⋯ D​N, where D​iis the distance between the i-th and the (i+1)-st exits, and D​N is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10 7), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^​7
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:
3
10
7

题目大意:

  • 输入的各个点围成一个环,其中相邻两个点之间的距离为输入的值
  • 计算两个点最小的距离

思路:

  • 先正序计算,总体减去,进行比较
#include <stdio.h>
const int MAXN=100010;
int array[MAXN];
int array1[MAXN];
void swap(int &a,int &b){
	a=a^b;
	b=a^b;
	a=a^b;
}
int main(){
	int n;
	scanf("%d",&n);
	
	int s=0;
	for(int i=1;i<=n;i++){
		scanf("%d",&array[i]);
		s+=array[i];
		array1[i]=s;
	}
	int m;
	scanf("%d",&m);
	while(m--!=0){
		int a,b;	
		scanf("%d%d",&a,&b);
		if(a>b)swap(a,b);
		int sum=0;
		sum = array1[b-1]-array1[a-1];
		sum = sum<s-sum?sum:s-sum;
		printf("%d\n",sum);
		
	}
} 
发布了91 篇原创文章 · 获赞 9 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/WeDon_t/article/details/105150943