AtCoDeer and Rock-Paper

6474: AtCoDeer and Rock-Paper

时间限制: 1 Sec  内存限制: 128 MB
提交: 133  解决: 82
[提交][状态][讨论版][命题人:admin]

题目描述

AtCoDeer the deer and his friend TopCoDeer is playing a game. The game consists of N turns. In each turn, each player plays one of the two gestures, Rock and Paper, as in Rock-paper-scissors, under the following condition:
(※) After each turn, (the number of times the player has played Paper)≤(the number of times the player has played Rock).
Each player's score is calculated by (the number of turns where the player wins) − (the number of turns where the player loses), where the outcome of each turn is determined by the rules of Rock-paper-scissors.
(For those who are not familiar with Rock-paper-scissors: If one player plays Rock and the other plays Paper, the latter player will win and the former player will lose. If both players play the same gesture, the round is a tie and neither player will win nor lose.)
With his supernatural power, AtCoDeer was able to foresee the gesture that TopCoDeer will play in each of the N turns, before the game starts. Plan AtCoDeer's gesture in each turn to maximize AtCoDeer's score.
The gesture that TopCoDeer will play in each turn is given by a string s. If the i-th (1≤i≤N) character in s is g, TopCoDeer will play Rock in the i-th turn. Similarly, if the i-th (1≤i≤N) character of s in p, TopCoDeer will play Paper in the i-th turn.

Constraints
1≤N≤105
N=|s|
Each character in s is g or p.
The gestures represented by s satisfy the condition (※).

输入

The input is given from Standard Input in the following format:
s

输出

Print the AtCoDeer's maximum possible score.

样例输入

gpg

样例输出

0

提示

Playing the same gesture as the opponent in each turn results in the score of 0, which is the maximum possible score.

来源

ABC046&ARC062 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

int main()
{
    char str[100005];
    scanf("%s",str);

    int len = strlen(str);
    int ans = 0;
    int paper = 0;

    for(int i=0;i<len;i++)
    {
        if(str[i]=='g')
        {
            if(paper>0)
            {
                ans++;
                paper--;
            }
            else
            {
                paper++;
            }
        }
        else
        {
            if(paper>0)
            {
                paper--;
            }
            else
            {
                paper++;
                ans--;
            }
        }
    }
    cout<<ans<<endl;
}

猜你喜欢

转载自www.cnblogs.com/hao-tian/p/9098189.html