《算法笔记》6.1小节——C++标准模板库(STL)介绍->vector的常见用法详解

目录

问题 A: Course List for Student (25)

问题 B: Student List for Course (25)


问题 A: Course List for Student (25)

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

翻译

有N个学生,K门课,给出选择每门课的学生姓名,最后对于给出的N个学生的姓名的选课情况进行询问,要求按顺序给出每个学生的选课情况。

题解

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 26 * 26 * 26 * 10 + 1;//将名字唯一的对应成数字有maxn种
vector<int> hashTable[maxn];
int transfer(char str[]){//将字符串转化成整型数字
	int id = 0;
	int i;
	for(i = 0; i < 3; i++){
		id = id * 26 + str[i] - 'A';
	}
	id = id * 10 + str[3] - '0';
	return id;
}
int main(){
	int n, k, i, count;
	char name[5];
	vector<int>::iterator it;
	scanf("%d%d", &n, &k);
	int j, l;
	for(j = 0; j < k; j++){
		scanf("%d%d", &i, &count);//i表示课程代号,count表示选课学生的数量
		for(l = 0; l < count; l++){
			scanf("%s", name);
			hashTable[transfer(name)].push_back(i);//将课程代码存入对应学生的hash中
		}
	}
	for(j = 0; j < n; j++){
		scanf("%s", name);
		printf("%s %d", name, hashTable[transfer(name)].size());
		if(hashTable[transfer(name)].size()){//如果该学生没有选课就不输出课程代码
			sort(hashTable[transfer(name)].begin(),hashTable[transfer(name)].end());//将课程代码顺序输出
			for(it = hashTable[transfer(name)].begin(); it != hashTable[transfer(name)].end(); it++){
				printf(" %d", *it);
			}
		}
		printf("\n");
	}
	return 0;
}

问题 B: Student List for Course (25)

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

输入

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

输出

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

样例输入

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

样例输出

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题解

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> hashTable[2510];//存储课程代码
char stu[40010][5];//存储学生名字
bool cmp(int a, int b){
	return strcmp(stu[a], stu[b]) < 0;
}
int main(){
	int n, k, i, count;
	char name[5];
	vector<int>::iterator it;
	scanf("%d%d", &n, &k);
	getchar();
	int j, l;
	for(j = 0; j < n; j++){
		scanf("%s %d", stu[j], &count);//输入学生姓名并放入唯一的数组中
		for(l = 0; l < count; l++){
			scanf("%d", &i);
			hashTable[i].push_back(j);//将学生名字对应的下标放入课程i的hashTable中
		}
	}
	for(j = 1; j <= k; j++){
		printf("%d %d\n", j, hashTable[j].size());
		sort(hashTable[j].begin(), hashTable[j].end(), cmp);//将这一个课程代码对应的学生名字排序
		for(it = hashTable[j].begin(); it != hashTable[j].end(); it++){//输出所有的学生名字
			printf("%s\n", stu[*it]);
		}
	}
	return 0;
}
发布了160 篇原创文章 · 获赞 175 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/wyatt007/article/details/104876911