Rightmost Digit ---HDU1061

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37888    Accepted Submission(s): 14268


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
234
 

Sample Output
76
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

//快速幂或者打表找规律

#include <iostream>
#include <bits/stdc++.h>

using namespace std;
//快速幂
long long f(long long a,long long b)
{
   long k=1;
   a%=10;
   while(b)
   {
      if(b%2==1)
      k=(k*a)%10;
      b/=2;
      a=(a*a)%10;
   }
   return k;
}
int main()
{
    long long t,x;
    cin>>t;
    while(t--)
    {
        scanf("%lld",&x);
        printf("%lld\n",f(x,x));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/stanmae/article/details/80384886