1037 Magic Coupon (25分)【贪心】

1037 Magic Coupon (25分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题目大意:

给出两个集合,从这两个集合中分别选取相同数量的元素进行一对一相乘,问能得到的乘积之和最大是多少。

解题思路:

为保证乘积之和最大,我们采用贪心的思想:对于负数最小的和最小的相乘;而对于正数最大的和最大的相乘;如果两个数的乘积小于零,则抛弃。

#include<iostream>
#include<algorithm>
using namespace std;

int arrc[100010];
int arrp[100010];

int main()
{
	int nc, np;
	cin >> nc;
	for (int i = 0; i < nc; i++)
	{
		cin >> arrc[i];
	}
	cin >> np;
	for (int i = 0; i < np; i++)
	{
		cin >> arrp[i];
	}
	sort(arrc, arrc + nc);
	sort(arrp, arrp + np);
	int hc = 0, hp = 0, tc = nc - 1, tp = np - 1;
	int maxs = 0;
	while (arrc[hc] < 0 && arrp[hp] < 0 && hc < nc&&hp < np)
	{
		maxs += (arrc[hc] * arrp[hp]);
		hc++;
		hp++;
	}
	while (arrc[tc] > 0 && arrp[tp] > 0 && 0 <= tc && 0 <= tp)
	{
		maxs += (arrc[tc] * arrp[tp]);
		tc--;
		tp--;
	}
	cout << maxs << endl;
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104772858
今日推荐