【PAT】1025. PAT Ranking (25)

题目


链接:https://www.patest.cn/contests/pat-a-practise/1025

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4




分析


题意:

根据score进行排序
输出:编号 总排名 所属的地区 所在地区中的排名

坑点:

相同score,再根据编号大小进行排名




题解(已AC)


/**
    根据分数进行排序
    1. 按分数从高到低
    2. 同分数
        按registration_number排高低(从小到大)
*/


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct RankNode {
    char registration_number[15];
    int final_rank;
    int location_number;
    int local_rank;
    int score;
};

int N;
int k;
int K;  //总数
RankNode List[30005];

bool complare(RankNode a, RankNode b) {
    return a.score != b.score ? a.score > b.score : strcmp(a.registration_number, b.registration_number) < 0;
}

void sortList(RankNode nodeList[], int n) {
    sort(nodeList, nodeList + n, complare);
    int local_rank = 1;
    int score = 101;
    for (int i = 0; i < n; ++i) {
        if (score > nodeList[i].score) {
            local_rank = i + 1;
            score = nodeList[i].score;
        }
        nodeList[i].local_rank = local_rank;
    }
}

void sortAll() {
    sort(List, List + K, complare);

    int score = 101;
    int final_rank = K;
    for (int i = 0; i < K; ++i) {
        if (score > List[i].score) {
            final_rank = i + 1;
            score = List[i].score;
        }
        List[i].final_rank = final_rank;
    }
}

int main(void) {

    int location = 1;

    scanf("%d", &N);

    for (int i = 0 ; i < N; ++i) {
        scanf("%d", &k);

        RankNode nodeList[305];
        for (int j = 0; j < k; ++j) {
            scanf("%s %d", &nodeList[j].registration_number, &nodeList[j].score);
            nodeList[j].location_number = location;
        }
        location ++;
        sortList(nodeList, k);



        for (int j = 0; j < k; ++j) {
            List[j + K] = nodeList[j];
        }
        K += k;
    }

    sortAll();

    printf("%d\n", K);
    for (int j = 0; j < K; ++j) {
        printf("%s %d %d %d\n", List[j].registration_number, List[j].final_rank
               , List[j].location_number, List[j].local_rank);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/fanfan4569/article/details/79225192