Constructing Roads(并查集)

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179
#include <iostream>
#include <algorithm>
#include <cstdio>
#define rush() int T;cin>>T;while(T--)
#define go(a) while(cin>>a)
#define ms(a,b) memset(a,b,sizeof a)
#define E 1e-8
using namespace std;
typedef long long ll;
const int N=100+5;

    int n,m,t;
    int a[N][N];
    int fa[N];
    int i,j,k;

struct Edge
{
    int u,v,valu;
    bool const operator<(const Edge &b)
    const{
        return valu<b.valu;
    }
}edge[N*N];
int Find(int son)
{
    return son==fa[son] ? son : fa[son]=Find(fa[son]);
}
bool Union(int x,int y)
{
    x=Find(x),y=Find(y);
    if(x==y) return 1;
    else{
        fa[y]=x;
        return 0;
    }
}
int main()
{
    cin.tie(0);istream::sync_with_stdio(false);
    while(cin>>n){
        for(i=1;i<=n;i++) fa[i]=i;

        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                cin>>a[i][j];

        rush(){
            int x,y;
            cin>>x>>y;
            a[x][y]=a[y][x]=0;
        }

        int num=0;
        for(i=1;i<=n;i++){
            for(j=i+1;j<=n;j++){
                edge[++num].u=i;
                edge[num].v=j;
                edge[num].valu=a[i][j];
            }
        }

        int ans=0;
        stable_sort(edge+1,edge+1+num);
        for(i=1;i<=num;i++){
            if(0==Union(edge[i].u,edge[i].v))
                ans+=edge[i].valu;
        }
        cout<<ans<<endl;
    }
}
原创文章 410 获赞 16 访问量 3万+

猜你喜欢

转载自blog.csdn.net/C_Dreamy/article/details/106104163