Period hdu 1358(kmp&前缀的周期性)

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:确定字符串的每个前缀是否为周期性,如:aabaabaa,前两个字母(aa)为周期性,前三个,前四个,前五个都不是,前六个(aabaab)是周期性的。

思路:next数组性质的运用,只需遍历找每个前缀的循环节跟前缀的长度是否为倍数关系即可,具体看代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=1e6+10;
char a[N];
int net[N];
void getnext()
{
    net[0]=-1;
    int k=-1,j=0,len=strlen(a);
    while(j<len)
    {
        if(k==-1||a[j]==a[k])
            net[++j]=++k;
        else k=net[k];
    }
}
int main()
{
    int n,k=1;
    while(~scanf("%d",&n)&&n)
    {
        scanf("%s",a);
        getnext();
        printf("Test case #%d\n",k++);
        for(int i=1;i<n;i++)
        {
            int tmp=i+1-net[i+1];
            if((i+1)%tmp==0&&(i+1)/tmp>1)
                printf("%d %d\n",i+1,(i+1)/tmp);
        }
        printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/never__give__up/article/details/80402479