Dungeon Master(bfs)广度优先搜索

描述

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

输入

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

输出

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

样例输入

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

样例输出

Escaped in 11 minute(s).
Trapped!

一定要清空队列清空队列清空队列!!!
就是个三维迷宫,没做过二维的话建议先去刷一下二维。
其实这个题没有什么坑点

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <math.h>
#include <string>
#include <list>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <algorithm>
#define maxn  1000000
const int MaxN=0x3f3f3f3f;
const int MinN=0xc0c0c00c;
typedef long long ll;
using namespace std;
char a[40][40][40];
int cnt ,num,n,k;
bool visited[40][40][40];
struct wazxy{
    int x,y,z;
    int steps;
};
queue <wazxy>  q;
int dx[6]={0,0,0,0,-1,1};
int dy[6]={0,-1,0,1,0,0};
int dz[6]={1,0,-1,0,0,0};//表示六个方向
wazxy node,temp;
int ans=0;
void bfs(int x,int y,int z,int steps){
    node.x=x,node.y=y,node.z=z,node.steps=steps;
    q.push(node);
    while(!q.empty()){   //基本的bfs操作
        temp=q.front();
        q.pop();
        if(a[temp.x][temp.y][temp.z]=='E'){
            ans=temp.steps;
            break ;
        }
        for(int i=0;i<6;i++){
            node.x=temp.x+dx[i];
            node.y=temp.y+dy[i];
            node.z=temp.z+dz[i];
            if(visited[node.x][node.y][node.z]&&(a[node.x][node.y][node.z]=='.'||a[node.x][node.y][node.z]=='E')){   //判断下一个点是否可以走
                visited[node.x][node.y][node.z]=false;  //一定不要忘记去重
                node.steps=temp.steps+1;
                q.push(node);
            }
        }
    }
    return ;
}
int main()
{
    int n,m,k;
    while(cin>>n>>m>>k){
        if(n==0)  break;
        getchar();
        memset(a,0,sizeof(a));
        while(!q.empty())  q.pop();   //不要忘记清空队列!!!!
        int x,y,z;
        for(int i=1;i<=n;i++)   //都从1开始的话就省去了判断边界这一过程了,我觉得这个方法还是挺实用的
        for(int f=1;f<=m;f++)
        for(int j=1;j<=k;j++){
            cin>>a[i][f][j];
            if(a[i][f][j]=='S'){
                x=i,y=f,z=j;
            }
        }
        memset(visited,true,sizeof(visited));
        ans=0;
        bfs(x,y,z,0);
        if(ans==0){
            cout<<"Trapped!"<<endl;
        }
        else  cout<<"Escaped in "<<ans<<" minute(s)."<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xxxxxiao123/article/details/104315540