困难的串 UVA129

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants
have very high mental and physical abilities. In one section of the contest the contestants are tested on
their ability to recall a sequenace of characters which has been read to them by the Quiz Master. Many
of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to
this test, the organisers have decided that sequences containing certain types of repeated subsequences
should not be used. However, they do not wish to remove all subsequences that are repeated, since in
that case no single character could be repeated. This in itself would make the problem too easy for the
contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining
identical subsequences. Sequences containing such an occurrence will be called “easy”. Other sequences
will be called “hard”.
For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the
subsequence CB. Other examples of easy sequences are:
• BB
• ABCDACABCAB
• ABCDABCD
Some examples of hard sequences are:
• D
• DC
• ABDAB
• CBABCBA
In order to provide the Quiz Master with a potentially unlimited source of questions you are asked
to write a program that will read input lines from standard input and will write to standard output.
Input
Each input line contains integers n and L (in that order), where n > 0 and L is in the range 1 ≤ L ≤ 26.
Input is terminated by a line containing two zeroes.
Output
For each input line prints out the n-th hard sequence (composed of letters drawn from the first L letters
in the alphabet), in increasing alphabetical order (Alphabetical ordering here corresponds to the normal
ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The
first sequence in this ordering is ‘A’. You may assume that for given n and L there do exist at least n
hard sequences.
As such a sequence is potentially very long, split it into groups of four (4) characters separated by
a space. If there are more than 16 such groups, please start a new line for the 17th group.
Your program may assume a maximum sequence length of 80.
For example, with L = 3, the first 7 hard sequences are:
A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA
Sample Input
7 3
30 3
0 0
Sample Output
ABAC ABA
7
ABAC ABCA CBAB CABA CABC ACBA CABA

#include<stdio.h>
#include<string.h>
int s[100];
int n, l,num;//用num存储字典序

bool judge(int cur)
{
	int j, k;
	for (j = 1; j * 2 <= cur + 1; j++)//后缀长度从1判断到cur+1,+1是考虑到奇数情况
	{
		bool flag = true;
		for (k = 0; k < j; k++)
			if (s[cur - k] != s[cur - k - j])//前后不相同才合法
			{
				flag = false;
				break;
			}
		if (flag) //说明某一后缀长度时出现相同的情况,说明不合法
			return false;
	}
	return true;
}

void output(int cur)
{
	for (int i = 0; i <= cur; i++)
	{
		if (i % 4 == 0 && i>0)
		{
			if (i % 64 == 0 && i>0)
				putchar('\n');
			else
				putchar(' ');
		}
		putchar(s[i]);
	}
	printf("\n%d\n", cur + 1);
}

bool dfs(int cur)//cur为字母个数
{
	int i;
	for (i = 0; i < l; i++)
	{
		s[cur] = 'A'+i;
		if (judge(cur))
		{
			num++;//每次只要判断正确就+1,但个数可能不变
			if (num == n)
			{
				output(cur);
				return true;
			}
			if (dfs(cur+1))
			return true;	
		}	
	}
	return false;
	
}

int main()
{
	while (scanf("%d%d", &n, &l) != EOF, n + l)
	{
		num = 0;
		dfs(0); 
	}
}

猜你喜欢

转载自blog.csdn.net/qq_41991981/article/details/81462697